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1
 Using XDocsFMx
XDocsFMx v.1.0 - 29 October 2009

XDocsFMx integrates XDocs 2.0 or 2.1 with DITA-FMx 1.1 to provide you with 
a seamless document management, authoring, and publishing environment.

This FrameMaker/XDocs connector was developed by Leximation, Inc. For 
questions regarding the functionality within FrameMaker, please contact Lexi-
mation at <tools AT leximation DOT com>. Any questions regarding the 
XDocs CMS should be directed at Bluestream Inc.

The online Help available from the Help buttons and Help menu in XDocsFMx 
does not include the screenshots of the user interface dialog boxes and menus. 
If you’d like to review documentation that includes these images, please refer to 
the web-based documentation at docs.leximation.com/xdocsfmx/1.0/ (a PDF is 
also available at that location).

RELATED TOPICS:
"Installation and Setup" on page 5
"XDocsFMx Commands" on page 9
"Preferences" on page 15
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USING XDOCSFMX
CREATING REFERENCES
Creating References

Overview of the process used to insert xrefs and conrefs.

You’ll use the DITA-FMx Reference Manager to create references (xrefs, links, 
and conrefs) in your DITA files. By default, the File Location list lets you create 
references to other files open in FrameMaker (these files will be listed in the 
Source File list). If you want to create references to files in the repository, select 
the File Location browse button (“...”) to browse directories in the XDocs server.

Figure 1: DITA-FMx Reference Manager

When you select a directory in the Resources list, that directory will be added to 
the File Location list and will be available for quick access from the Reference 
Manager. You can add up to 10 directory locations.
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USING XDOCSFMX
GENERATING A BOOK FROM A MAP
Figure 2: Browse Directories Dialog Box

Generating a Book from a Map

The DITA-FMx “Book from Map” command lets you create a PDF-ready 
FrameMaker book from a DITA map or bookmap.

One of the primary reasons to use FrameMaker as a DITA authoring tool is its 
ability to easily create high quality PDFs. DITA-FMx provides the “Generate 
Book from Map” command which gives you a high degree of control over most 
aspects of the map-to-book processing. The “Setting up Book Builds” topic in 
the DITA-FMx online Help provides all of the information you need to prepare 
for this processing. 

Generating a book from XDocs-sourced content requires two additional steps:

• Specify the DITA-XDFMx-Book structure application as the “Book” 
structure application in the DITA-FMx Options dialog.

• Set a value for the “href_prefix” variable in the cms-prefix.xsl file to match 
your “checkout directory” (as defined in the Configure Servers dialog box 
in the XDocs Explorer). The cms-prefix.xsl file is in the 
DITA-XDFMx-Book application directory (typically FrameMaker/Struc-
ture/xml/DITA-XDFMx-Book/Book).

Once this has been done, follow these steps:

1) Download all of the files in the book (map, topic, and image files) to the 
local file system. The easiest way to do this is to use the Download 
command in the XDocs Explorer, and select the folder that contains the 
XDOCSFMX USER GUIDE 3



USING XDOCSFMX
GENERATING A BOOK FROM A MAP
files. If your book contains references to files in multiple folders, make 
sure to download those files as well.

2) Open the root map file using the Get File command on the XDocs menu.

3) Choose Generate Book from Map on the DITA-FMx menu. You will be 
prompted for a location for the new book file. It is best to select a location 
outside of the XDocs checkout directory.

4) After the book file has been created, review the files for proper numbering, 
pagination and setup. If everything looks good, use the Save As PDF 
command to create a PDF of your book.

Remember that the book and FM files that are generated by this process are not 
intended to be edited. You should always make edits to the source DITA files 
and regenerate the book. Any edits or modifications you make to the generated 
FM files will be lost the next time you build the book.

However, you can add new files to the book such as a title page or other unstruc-
tured content. The next time you generate a book, you’ll just need to add that 
unstructured content back into the book, but you won’t have to recreate it.

RELATED TOPICS:
"Updating the Structure Applications" on page 6
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2
 Installation and Setup
To install XDocsFMx, complete the instructions in the following topics. For 
additional information such as structure application customization, refer to the 
DITA-FMx documentation.

RELATED TOPICS:
"Using XDocsFMx" on page 1
"XDocsFMx Commands" on page 9

Install DITA-FMx

XDocsFMx requires the prior installation of DITA-FMx 1.1. Before installing 
XDocsFMx be sure to complete the DITA-FMx installation. If you’re only using 
DITA-FMx with content from the XDocs repository, you can omit the installa-
tion of the default DITA-FMx structure applications and just install the 
XDocsFMx apps (although, we recommend that you install all of the structure 
applications for greatest flexibility).

After DITA-FMx has been installed, continue to Running the Installer.

Running the Installer

After DITA-FMx has been installed, run the XDocsFMx installer application. 
Follow the installation prompts to install on FM8 or FM9. This will copy the 
following files into the FrameMaker\DITA-FMx folder:

XDocsFMx_<ver>.dll
The client plugin file (different versions for FM8 and FM9).
5



INSTALLATION AND SETUP
UPDATING THE STRUCTURE APPLICATIONS
XDocs.chm
The XDocsFMx online Help file.

XDocsFMx_apps.zip
The ZIP archive of the structure applications used with XDocsFMx. The 
contents of this file must be extracted to the FrameMaker/Structure/xml 
folder and set up as available structure applications in the structure appli-
cation definitions file.

After the installation application has finished, continue to Updating the Struc-
ture Applications.

Updating the Structure Applications

In general, the structure applications that are provided with DITA-FMx (or 
those that you’ve customized) will work properly with XDocsFMx. However, 
there is one element definition in the typical Topic structure application that 
needs minor refinement and the import XSLT script in the Book application 
needs to be updated. Sample Topic and Book applications are provided as well 
as instructions for modifying your existing apps.

The image element definition in the Topic application will typically include the 
following context rule:

Initial graphic element format 
    In all contexts. 
        Insert imported graphic file.

This rule tells FrameMaker to display a file dialog for selecting an image file to 
insert into the image element. If you’re working on the local file system, this is 
useful, but when you are using XDocs, you should be browsing the repository 
for image files.

In order to prevent the local file dialog from displaying, and to allow the repos-
itory browser to display, you should remove this context rule from the image 
element definition. This only affects the Topic app, the standard Map and Book 
apps do not need to be modified in any way.

You may want to clone your Topic app (be sure to go through the complete app 
cloning process as described in the DITA-FMx documentation) to create one 
that’s used when working with files in XDocs and one that’s used for working 
with files on your local file system. A sample Topic app is provided in the 
XDocsFMx installation folder.
 6 XDOCSFMX USER GUIDE



INSTALLATION AND SETUP
UPDATING THE STRUCTURE APPLICATIONS
A sample Book application is also provided. This structured application is iden-
tical to the default DITA-FMx Book app other than the import XSLT script. 
This script has been modified to prepend the cache root path to all @href values 
to allow the paths to properly resolve on the local file system. Note that this 
Book application will not work properly with files that were not extracted from 
XDocs. 

The following steps describe the installation of the structure applications 
provided with XDocsFMx (this is identical to the process used to install the 
DITA-FMx structure applications, with the exception of the file and application 
name). The Map application is identical to the default DITA-FMx Map applica-
tion, while the Topic and Book applications have been modified as described 
above.

1) (Optional) Make a backup copy of your current structure application defi-
nitions file (typically found at FrameMaker\Structure\structapps.fm for 
FM8, or <user appdata>\Adobe\FrameMaker\9 for FM9). Store this file in 
a safe location before making modifications.

2) Extract the contents of the XDocsFMx_apps.zip file to the 
FrameMaker\Structure\xml folder. This will create a folder named 
DITA-XDFMx that contains folders named Book, dtd, Map, and Topic. 
These folders contains the three structure application as well as the DITA 
1.1 DTD files used by the applications.

3) Start FrameMaker and open the structure application definitions file 
(Structure Tools > Edit Application Definitions).

4) In the structure application definitions file place the insertion point just 
after the Version element. 

5) Choose File > Import > File, then navigate to the struc-
tapps-stub_topic_1.1.fm file in the DITA-XDFMx\Topic folder created in 
step 2. Select the Import by Reference option and choose the Import 
button. In the next dialog accept the defaults and choose Import.

6) Repeat steps 4 and 5 for the “structapps-stub” files in the 
DITA-XDFMx\Map and DITA-XDFMx\Book folders.

7) Save the file, then choose Structure Tools > Read Application Defini-
tions.

8) Close the file and exit FrameMaker.

9) Restart FrameMaker and run the DITA-FMx > Options command and 
select DITA-XDFMx-Topic-1.1 for the DITA Topic Application, 
DITA-XDFMx-Map-1.1 for the DITA Map Application, and 
DITA-XDFMx-Book-1.1 for the DITA Book Application. 

NOTE: If your folder structure is non-standard, you may need to modify the paths 
specified in the “structapps-stub” files to match the file paths on your system. To 
XDOCSFMX USER GUIDE 7



INSTALLATION AND SETUP
UPDATING THE STRUCTURE APPLICATIONS
do this, just open the structure application definitions file and double-click each 
application’s text inset. In the dialog that displays, choose the Open Source button 
and make the changes in the “stub” file. When you have finished editing the stub 
file, save and close that file, then double-click the text inset again and choose the 
Update Now button. 

RELATED TOPICS:
"Generating a Book from a Map" on page 3
 8 XDOCSFMX USER GUIDE
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3
 XDocsFMx Commands
RELATED TOPICS:
"Using XDocsFMx" on page 1
"Installation and Setup" on page 5
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XDOCSFMX COMMANDS
LOGIN/LOGOUT
Login/Logout

Establishes the connection from FrameMaker to the XDocs server.

Use the Login command to connect to the selected XDocs server. Enter your 
user name and password, then select the server name to use. If you’d like your 
password saved between sessions, select the Remember Login Credentials 
option. Once successfully logged in to the XDocs server, the commands on the 
XDocs menu are enabled.

Figure 1: XDocs Login Dialog Box

Use the Logout command to disconnect from the current server.

RELATED TOPICS:
"Preferences" on page 15
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XDOCSFMX COMMANDS
CREATE NEW FILE
Create New File

Create a new file on the server and open it for editing.

Use the Create New File command to add a new file to the XDocs server and 
open that new file in FrameMaker for editing. The Folder and Resources lists let 
you browse for the location to create the new file. The selected file in the Use 
Template list specifies the template that will be used for the new file. Enter the 
new file name and choose OK.

If you type a new file name without a file extension, one will be added that 
matches that of the selected template. DITA map files must always have a 
“.ditamap” extension.

Figure 2: New File Dialog Box

The new file is created on the server in the specified folder, then checked out and 
opened in FrameMaker for editing.

Use the Refresh button to update the list of folders if they have changed on the 
server since logging in to the XDocs server.
XDOCSFMX USER GUIDE 11



XDOCSFMX COMMANDS
GET FILE
Get File

Open a file for viewing or referencing.

Use the Get File command to open a file for viewing. If the Open File in Editor 
option is not selected, the file will be fetched but not opened in FrameMaker.

Double-clicking a file in the Resources list will fetch the selected file and leave 
the dialog box open to allow the opening of multiple files. Select a file and 
choose Get to fetch the file then close the dialog.

Figure 3: Get File Dialog Box

Use the Refresh button to update the list of folders if they have changed on the 
server since logging in to the XDocs server.

You can specify the appearance of the labels in the Resources list by selecting the 
appropriate option in Preferences. If a file is checked out (and thus locked), the 
username of the owner will be indicated in angle brackets.
 12 XDOCSFMX USER GUIDE



XDOCSFMX COMMANDS
CHECK OUT FILE
Check Out File

Open a file for editing.

Use the Check Out File command to open a file for editing. If the Open File in 
Editor option is not selected, the file will be fetched and checked out but not 
opened in FrameMaker. When you close the file you will be prompted to check 
the file back in to the XDocs server (if this option is enabled in Preferences).

Double-clicking a file in the Resources list will fetch the selected file and leave 
the dialog box open to allow the opening of multiple files. Select a file and 
choose Check Out to fetch and check out the file then close the dialog.

Figure 4: Chek Out File Dialog Box

Use the Refresh button to update the list of folders if they have changed on the 
server since logging in to the XDocs server.

You can specify the appearance of the labels in the Resources list by selecting the 
appropriate option in Preferences. If a file is checked out (and thus locked), the 
username of the owner will be indicated in angle brackets.

RELATED TOPICS:
"Preferences" on page 15
XDOCSFMX USER GUIDE 13



XDOCSFMX COMMANDS
CLOSE/CHECK IN CURRENT FILE
Close/Check In Current File

Close and check in the current file.

Use this command to close and check in the current file. This command is useful 
if you have disabled the “Prompt for Check In” option in Preferences.

Check Out Current File

Check out the file that’s currently open for viewing.

Use this command to check out the currently open file. This command is useful 
if you have opened a file that is only available for viewing (read-only access), but 
decided that you actually need to edit it. It is also useful if you want to edit a file 
that is opened as the source of a conref or xref by using the Edit button in the 
Reference Manager.

NOTE: The current file is closed then if it is available for editing it is reopened with 
read-write access. If the file is not available for editing (if it’s already checked out 
to someone else), the file will be reopened for viewing.

Delete Recover Files

Deletes the recover files created by FrameMaker after a crash.

When FrameMaker crashes, it is likely that any open files are saved as “recover” 
files (these files have “.recover” before the file extension). These files are saved 
as FrameMaker binary files even if you are editing XML files. This command 
reports on the number of recover files in the cache directory and allows you to 
delete them.

When you restart FrameMaker after a crash and try to reopen a file that was 
open during the crash, you will be prompted to open the recover file instead. In 
general you want to choose “No” at this prompt, so you can open the XML file. 
If you do this and find that you are missing content that you hoped would have 
been saved, you can manually open the recover file by using File > Open then 
browsing to the cache directory and selecting the recover file. Copy and paste 
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XDOCSFMX COMMANDS
PREFERENCES
the missing content from the recover file into the XML file, then close the 
recover file. 

IMPORTANT: It is important that you do not open the recover file, then save it as 
if it were an XML file. It is likely that you will replace the XML file with a 
FrameMaker binary file which will cause problems for the authoring process as 
well as when you try to check the file back in to the XDocs server.

Preferences

Customize the functionality of the connector and the appearance of certain 
dialog boxes.

Provides access to the user definable options in XDocsFMx. 

Figure 5: Preferences Dialog Box

If the “Prompt for Check In ...” option is selected, you are prompted to check in 
a file when it closes. 

If the “When Following Topic References ...” option is set to Ask, the following 
dialog box displays when you double-click a topic reference in a DITA map.
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XDOCSFMX COMMANDS
PREFERENCES
Figure 6: XDocs Open Reference Dialog Box

Select one of the “Labels in File Browser” options to control how files are repre-
sented in the various file browser dialog boxes.

RELATED TOPICS:
"Create New File" on page 11
"Check Out File" on page 13
"Login/Logout" on page 10
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